Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 17:00 AWST
Scheduled
We will be performing scheduled maintenance to the MyPass platform between 05:00 PM - 05:30 PM AWST on 27 March 2025. During this time, you may experience longer load times or be unable to access MyPass. If this occurs, please try reloading your page or visit us again after our maintenance period ends. We appreciate your understanding and apologise for any inconvenience this may cause.
Posted Mar 27, 2025 - 12:13 AWST
This scheduled maintenance affected: Industry Portal and Skills Passport.