Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 13, 2026 - 20:00 AWST
Scheduled
We will be performing scheduled maintenance to the MyPass platform on 13 Jan 2026 between 08:00 PM - 11:00 PM AWST. Please contact support for more information. During this time you may experience longer load times or be unable to access MyPass. If this occurs, please try reloading your page or visiting us again after our maintenance period ends. We appreciate your understanding and apologise for any inconvenience this may cause.
Posted Jan 13, 2026 - 13:43 AWST
This scheduled maintenance affected: Industry Portal, Skills Passport, API, and Messaging Service.