Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 20:00 AWST
Scheduled
We will be performing scheduled maintenance to the MyPass platform on 20 January 2026 between 8:00 PM - 8:30 PM AWST. Please contact support for more information.
Posted Jan 20, 2026 - 11:00 AWST
This scheduled maintenance affected: Industry Portal, Skills Passport, API, and Messaging Service.